Results 1 to 6 of 6
  1. #1
    Junior Member Baited's Avatar
    Join Date
    Oct 2017
    Posts
    13

    Token used elsewhere.

    All of my servers but one has generated a token successfully, however, when I put one on my 6th server it displays the correct token but states it was used elsewhere, I checked with numerous tokens and all show as used elsewhere, it's been happening for two days now and no matter when I generate a new one it still states the token I generated is used elsewhere :/

  2. #2
    Closing the void Neuro Toxin's Avatar
    Join Date
    Aug 2014
    Location
    Melbourne
    Posts
    1,807
    Maybe you have a token in the command line or auto exec config?
    http://www.aus-tg.com

    Quote Originally Posted by Batman View Post
    oh ye i scammed luvchopz

  3. #3
    Junior Member Baited's Avatar
    Join Date
    Oct 2017
    Posts
    13
    Quote Originally Posted by Neuro Toxin View Post
    Maybe you have a token in the command line or auto exec config?
    Checked, none are there as it's a direct copy of my other servers but obviously with the right token stuff.

    What happens is:
    I put in a token and restart the server, the server then reboots and displays
    *** tokenstash.com: Validating server token via HTTP...
    Jun 29 23:42:09: *** tokenstash.com: Token updated to 'REMOVEDE71E9465'.
    Jun 29 23:42:09: *** tokenstash.com: Server restarting! Jun 29 23:42:09: Connection to Steam servers successful.
    Jun 29 23:42:09: Public IP is xx.xx.xx.xx.
    Then, after like 5 minutes the server restarts and displays another message:

    Jun 29 23:42:56: *** tokenstash.com: Validating server token via HTTP...
    Jun 29 23:42:57: *** tokenstash.com: Current token is valid.
    Jun 29 23:42:57: Connection to Steam servers successful.
    Jun 29 23:42:57: Public IP is . Jun 29 23:42:57:
    Assigned persistent gameserver Steam ID [G:].
    Jun 29 23:42:57: VAC secure mode is activated.
    Jun 29 23:42:57: L 06/29/2018 - 23:42:57:
    Jun 29 23:43:24: * * Jun 29 23:43:24: * Steam account token was reused elsewhere.
    * Jun 29 23:43:24: * Make sure you are using a separate account
    * Jun 29 23:43:24: * token for each game server that you operate.
    * Jun 29 23:43:24: *
    * Jun 29 23:43:24: * To create additional game server accounts go to
    * Jun 29 23:43:24: * http://steamcommunity.com/dev/managegameservers
    * Jun 29 23:43:24: * * Jun 29 23:43:24: * This game server instance will now shut down!
    * Jun 29 23:43:24: * * Jun 29 23:43:24: ************************************************** **
    Then my second server goes down and comes back up once the server reboots.
    It's as if the server restarts and tries hijacking Server 2's token, realizes it's used then restarts which when Server 2 does it's restart goes "there's my token" and comes back.
    Any idea how I can actually fix it?
    Last edited by Baited; 30-06-2018 at 09:48 AM. Reason: More info

  4. #4
    Closing the void Neuro Toxin's Avatar
    Join Date
    Aug 2014
    Location
    Melbourne
    Posts
    1,807
    Make sure both servers have different server keys in their configs.

    csgo/cfg/sourcemod/tokenstash.cfg
    http://www.aus-tg.com

    Quote Originally Posted by Batman View Post
    oh ye i scammed luvchopz

  5. #5
    Junior Member Baited's Avatar
    Join Date
    Oct 2017
    Posts
    13
    Quote Originally Posted by Neuro Toxin View Post
    Make sure both servers have different server keys in their configs.

    csgo/cfg/sourcemod/tokenstash.cfg
    they do, unless the plugin has issues with naming them "Server 1" "Server 2" "Server 3" "Server 4" etc?

    This has only occured since I updated the plugin to 1.0.0.
    Last edited by Baited; 30-06-2018 at 11:03 AM.

  6. #6
    Closing the void Neuro Toxin's Avatar
    Join Date
    Aug 2014
    Location
    Melbourne
    Posts
    1,807
    Could you do this for me (I'll credit tokens when your done and the issue is resolved).

    1. Make sure all servers are running the latest plugin package
    2. Login to the new site: https://dev.tokenstash.com/
    3. Click My Servers
    4. Click Generate New Config
    5. Copy the new config that is displayed (you should only have tokenstash_steamid and tokenstash_apikey displayed)
    6. Stop all servers
    7. Copy the new config to all your servers (csgo/cfg/sourcemod/tokenstash.cfg)
    8. Start all your servers
    9. They will reboot twice (once getting new server keys and again getting new tokens)

    Reply here when you are done and I'll credit your account back to 32 tokens + 5 more for your troubles (37 total).
    http://www.aus-tg.com

    Quote Originally Posted by Batman View Post
    oh ye i scammed luvchopz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •